Abstract

This work focuses mainly on the resistance of members to flexural buckling according to Eurocode 3. The work provides the mathematical backgrounds to the equations and buckling curves presented in Eurocode 3. The work also, attempts to reveal how different imperfections influence the flexural buckling resistance which is demonstrated through Finite Element (FE) simulations.

The work presents modeling and analysis on a steel column in ABAQUS 6.14. Linear and non-linear buckling analyses of the steel column, with the influence of imperfections, are implemented in this work. Specifically, the imperfections considered in this study are material plasticity, initial bow and residual stress.

The influence of initial bow imperfection of 0.1% of the length of the column considering flexural buckling was found to be 45.28% of the Euler buckling load. The influence of residual stresses, with a magnitude of maximum about 13% in the flange and 35% in the web, of the yielding strength, on flexural buckling is about 31.9% of the design Euler buckling load. The combined effect of residual stress and initial bow imperfection on flexural buckling is about 45.34% of the design Euler buckling load.

**Key words:** buckling curves, buckling resistance, Eigen-value, Eurocode 3, flexural buckling, initial bow imperfection, linear-buckling analysis, residual stress, Riks method.
Acknowledgement

This research work was in collaboration between Linnaeus University and Alstom, in Växjö, Sweden.

We thank Min Hu, who provided insights and expertise that helped greatly in this work and for being available any time for questions and to clear some of the doubts that arose along the way.

We also thank Marie Johansson, who provided us with some materials to get started with the work and for the lecture on Eurocodes which formed the basis of what was done in this work.

We would also like to show our gratitude to Sara Rydström, from Alstom, whose calmness and detailed explanation of what was to be done was valuable.

For me, Henry, this work has been produced during my scholarship period at Linnaeus University, thanks to a Swedish Institute scholarship.

Henry Mupeta, George John & Aliasgar Hirani

13th August, 2015.

Växjö, Sweden.
# Table of contents

**LIST OF SYMBOLS AND NOTATIONS**  ........................................................................................................................................ VI

**1. INTRODUCTION** ........................................................................................................................................................................ 1  
1.1 BACKGROUND ........................................................................................................................................................................ 1  
1.2 AIM AND PURPOSE ................................................................................................................................................................. 1  
1.3 METHOD, MATERIAL AND LIMITATIONS ............................................................................................................................................... 2

**2. LITERATURE REVIEW AND THEORY** ........................................................................................................................................ 3  
2.1 LITERATURE REVIEW ON BUCKLING ........................................................................................................................................... 3  
2.2 EULER BUCKLING THEORY ............................................................................................................................................................ 5  
2.3 FLEXURAL BUCKLING ACCORDING TO EUROCODE 3 .................................................................................................................... 10  
   2.3.1 Buckling resistance of members in compression ........................................................................................................................ 10  
   2.3.2 Buckling curves ........................................................................................................................................................................... 11

**3. BACKGROUND TO FLEXURAL BUCKLING IN EUROCODE 3** ................................................................................................ 16  
3.1 DERIVATION OF THE SECOND ORDER MOMENT ....................................................................................................................... 16  
3.2 REDUCTION FACTOR ......................................................................................................................................................................... 19

**4. CASE STUDY- INVESTIGATION OF THE INFLUENCE OF IMPERFECTIONS** ................................................................................ 25  
4.1 FLEXURAL BUCKLING RESISTANCE ACCORDING TO EUROCODE 3 ........................................................................................ 26  
   4.1.1 Cross section classification ......................................................................................................................................................... 26  
   4.1.2 Euler buckling load and non-dimensional slenderness ............................................................................................................. 28  
   4.1.3 Determination of buckling curve and imperfection factor .................................................................................................... 28  
   4.1.4 Calculation of the reduction factor ............................................................................................................................................ 30  
   4.1.5 Buckling resistance ....................................................................................................................................................................... 30  
   4.1.6 Buckling effects ............................................................................................................................................................................ 31  
   4.1.7 Initial local bow imperfection, ε₀ .............................................................................................................................................. 31  
4.2 FINITE ELEMENT MODELING ......................................................................................................................................................... 32  
   4.2.1 Boundary conditions ................................................................................................................................................................. 32  
   4.2.2 Material modeling ....................................................................................................................................................................... 33  
   4.2.3 True stress and true strain ............................................................................................................................................................ 33  
   4.2.4 Mesh and element ...................................................................................................................................................................... 35  
   4.2.5 Linear buckling analysis ............................................................................................................................................................... 36  
   4.2.6 Non-linear buckling analysis ...................................................................................................................................................... 36

**5. RESULTS AND ANALYSIS** .............................................................................................................................................................. 39  
5.1 LINEAR BUCKLING ANALYSIS ..................................................................................................................................................... 39  
5.2 CONVERGENCE STUDY ON THE LINEAR BUCKLING ANALYSIS .............................................................................................. 39  
5.3 NON-LINEAR BUCKLING ANALYSIS ........................................................................................................................................ 40  
   5.3.1 Initial bow imperfections ............................................................................................................................................................. 40  
   5.3.2 Residual stresses ......................................................................................................................................................................... 40  
   5.3.3 Combined residual stresses and initial bow imperfections .................................................................................................... 44

**6. COMPARISON OF BUCKLING CURVE C IN EUROCODE 3 AND ESTABLISHED FROM SIMULATION** .......................................................................................................................... 45  
6.1 MODEL WITH NON-DIMENSIONAL SLENDERNESS VALUE OF 1.2 .......................................................................................... 45  
6.2 MODEL WITH NON-DIMENSIONAL SLENDERNESS VALUE OF 2 ................................................................................................ 45

**7. DISCUSSION** .................................................................................................................................................................................. 45

**8. CONCLUSIONS** ................................................................................................................................................................................. 48

**REFERENCES** ................................................................................................................................................................................ 48

**APPENDIX** ...................................................................................................................................................................................... 52
List of symbols and notations

$A$  Cross-sectional area of a steel column
$A_{eff}$  Effective area of a cross-section
$b$  Breadth of a cross-section
$c$  Width of the flange or web
$e_0$  Initial bow imperfection amplitude
$E$  Modulus of elasticity
$f_y$  Yielding strength
$F_{max}$  Maximum of axial compressive force applied on a steel column
$h$  Height of a cross-section
$i$  Radius of gyration of a cross section
$i_y$  Radius of gyration along major axis
$i_z$  Radius of gyration along minor axis
$I$  Second moment of area
$I_y$  Second moment of area with respect to major axis
$I_z$  Second moment of area with respect to minor axis
$L$  Length of a column
$M(x)$  Bending moment at $x$ - position along the length of a column
$M_{ed}$  Design bending moment
$M_e$  External moment
$M_i$  Internal moment
$N$  Axial compressive load applied on a steel column.
$N_{b,Rd}$  Design buckling resistance of the compression member
$N_{cr}$  Elastic critical force for the relevant buckling mode
$N_{Ed}$  Design value of the compressive force
$N_{Rd}$  Design values of the resistance to normal forces
$t_f$  Thickness of the flange of a column along the cross-section.
$t_w$  Thickness of the web of a column along the cross-section.
$W_{el}$  Elastic section modulus
$x$  Predefined position along a column length
$y$  Deflection of a column at $x$ - position along the length of a column
$y(0)$  Deflection at starting point of a column
$y(L)$  Deflection at the end of a column
<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$y_{equ}$</td>
<td>Deflection of the column at yield point</td>
</tr>
<tr>
<td>$\alpha$</td>
<td>Imperfection factor</td>
</tr>
<tr>
<td>$\gamma_{M1}$</td>
<td>Partial factor for member buckling resistance</td>
</tr>
<tr>
<td>$\varepsilon$</td>
<td>Coefficient depending on the yield strength</td>
</tr>
<tr>
<td>$\varepsilon_{true}$</td>
<td>True strain</td>
</tr>
<tr>
<td>$\phi$</td>
<td>Intermediate factor</td>
</tr>
<tr>
<td>$\sigma_{cr}$</td>
<td>Critical elastic buckling stress</td>
</tr>
<tr>
<td>$\sigma_{true}$</td>
<td>True stress</td>
</tr>
<tr>
<td>$\bar{\lambda}$</td>
<td>Non-dimensional slenderness</td>
</tr>
<tr>
<td>$\lambda$</td>
<td>Geometric slenderness ratio of a column</td>
</tr>
<tr>
<td>$\lambda_r$</td>
<td>Reference relative slenderness at which $\sigma_{cr} = f_y$</td>
</tr>
<tr>
<td>$\chi$</td>
<td>Reduction factor for relevant buckling mode</td>
</tr>
</tbody>
</table>
1. Introduction

This project was in collaboration between Linnaeus University and Alstom. Alstom is a global player in the field of energy and transport infrastructure. In Växjö, Sweden, Alstom works with plants and system for cleaning of process gases to remove environmentally harmful substances such as nitrogen oxide, Sulphur dioxide and dust. Alstom has set the benchmark for innovative and environmentally conscious technologies.

1.1 Background

The design of steel structures has received massive research interests over the years. One of the main interests when designing steel structures is the member resistance to flexural buckling. The member slenderness and the imperfections are influential and play critical roles in the design process. Eurocode 3, which is a standard for steel structures for European Union (EU) member states, presents a couple of equations and buckling curves to help in the design process. However, there is no or little background to the equations and buckling curves presented on buckling resistance. For the inexperienced, the code easily becomes a cookbook that can be used without understanding the underlying problem. Moreover, more need to be done about the influence of imperfections on the resistance of members to flexural buckling according to Eurocode 3.

1.2 Aim and purpose

The work focused on understanding the background to the equations and buckling curves provided in Eurocode 3, simulation and analyzing a steel column in ABAQUS and studying how imperfections influence the member flexural buckling resistance. The aim of the study was to reveal the theoretical background behind the formulae and buckling curves of flexural buckling in Eurocode 3 and show how imperfections influence member’s flexural buckling resistance in accordance with Eurocode 3.

The purpose of this work was to present the derivation of the equations and the establishment of the buckling curves in Eurocode 3 and to provide a FE model of a steel column and demonstrate the influence of different imperfections on the buckling resistance.
1.3 Method, material and limitations

The Euler buckling theory was firstly studied to get an understanding to the buckling phenomenon. A theoretical study on section 5 and 6 of Eurocode 3 was carried out to get the background of how imperfections have been built into the formulae and buckling curves dealing with flexural buckling. This involves deriving the formulae in Eurocode3. The Finite Element (FE) model was thereafter created in ABAQUS 6.14. On this model, the linear buckling analysis was first performed followed by a non-linear buckling analysis using Riks method considering geometrical and residual stresses separately as well as the combined effect.

To study the effects of imperfections, a case study of a structural support of an electrostatic precipitator of a flue gas cleaning system was considered. The structure consists of 6 main support columns and a system of cross-bracings. This thesis considers the column experiencing the maximum load.

The work investigated mainly on a column having cross-section in class 3 and intermediate slenderness of 0.8. The loading case studied was pure compression. The load eccentricity was not included in this thesis due to the limited time. Additionally, only the pure compressive load and pined-pined boundary conditions were considered.
2. Literature review and theory

2.1 Literature review on buckling

Buckling is the deformation developed normal to the applied load on a member such as a column or beam [1]. Mainly, buckling happens in members subjected to some compressive forces. The higher the bending stiffness in a member, the higher the buckling resistance is. In particular, the buckling resistance decreases when the member length is increased. Thus, when the member is short with high bending stiffness the buckling resistance is high. Conversely, when the member is slender, the buckling resistance is low. Moreover, structural steel, when compared with other construction materials, has a higher yield strength as well as a higher ultimate strength. Therefore, compression steel members tend to be slender. Additionally, buckling is of particular interest when dealing with such members.

Recently, Ungermann et al. investigated local-flexural buckling interaction with plain channels based on the fact that different buckling failure modes do occur at the same time [2]. They discovered that a structure (specimen), that is not rigidly fixed and a load is applied on its centroid of its effective cross section, experiences a bending moment due to eccentricity leading to a decrease in local buckling strength. Additionally, for the rigidly fixed structure (specimen), the bending moment due to eccentricity does not influence the ultimate local buckling loads. When columns are loaded in compression as well as in bending, the supplementary bending moment prompts the flexural buckling collapse of the column [3]. Earlier on, Chan and Gardner [4] performed column tests to investigate the response of elliptical hollow sections to flexural buckling if the pin-ended compression members are experiencing axial loading. The researchers [4] chose their specimen lengths carefully to provide member slenderness spectrum, and discovered that the elastic buckling load was below yield load when buckling about the minor axis and the opposite was true when buckling about the major axis. Therefore, the ultimate load for slender members approaches the Euler buckling load. However, a thorough investigation by Trahair and Rasmussen [5] on what effects the concentrated oblique restraints have on flexural buckling of columns revealed that restraints may resist rotation as well as deflection. On one hand, the restraints may be elastic or rigid, on the other hand their concentration may be at a restraint point or simply distributed along a portion of the length of the column. Additionally, Adluri and Madugula [6] performed an experimental investigation to determine the flexural buckling strength of steel angles, focusing on residual stresses and material properties. A steel angle is steel that has been bent lengthwise to a certain angle, usually 90 degrees, and can be mostly used as braces to help in the reinforcement of structures or as brackets to provide needed support. Usually, residual stresses are expressed as a fraction of the yielding strength. However, the two may not be directly
related. The researchers [6] concluded that the maximum residual stress levels in steel angles are below 25% of the yielding strength.

The Euler buckling load equation does not consider imperfections. In reality, imperfections are always present. Two main types of imperfections are geometrical and material (mechanical) imperfections. Recently, Lopes and Real [7] analyzed the influences of initial geometrical and material imperfections on the determination of ultimate load of steel class 4 cross section elements at high temperatures. However, a lot still remains to be done on the influence of imperfection on flexural buckling on elements that are not subjected to fire or high temperatures. The researchers [7] argued that the imperfections must be considered according to the expected collapse mode. Studying the influence of imperfections on flexural buckling [2], the researchers concluded that residual stresses influence buckling behavior. However, the influence is small compared to the geometric imperfection. In their analysis, they discovered that for the specimen used the flexural buckling failure was a consistent one of the single half wave. Feng et al. [8] evaluated the sensitivity of column failure strength with regard to initial imperfections. Initial imperfection plays a critical role in the structural behavior prediction. The researchers [8] showed that the ultimate strength of short columns where the local buckling failure is predominant is influenced significantly by the magnitude of imperfections.

Finite Element Analysis, FEA, has been widely utilized to investigate the buckling behavior of steel columns, beams and frames. The major theme has always been that stainless steel columns which have been used in building massive and strong structures for a long time are subjected, in many ways, to buckling. Shu et al. investigated a design method for stainless steel column subjected to flexural buckling using FEA [9]. Their predictions of the finite element model correlated with the measured imperfection. The imperfections have a remarkable impact on the behavior and load-carrying capacity of columns in compression [3]. Additionally, the researchers [9] developed a finite element model that established the strength curves of columns failing in flexural buckling. However, no discussion involving columns with small slenderness, which may have a higher flexural buckling resistance, was done.

In a more detailed manner, the numerical modeling of flexural buckling of elliptical hollow section was investigated using ABAQUS [4]. The researchers chose the four-noded, reduced integration shell elements for their Finite Element (FE) models. In addition, a mesh convergence study was performed to choose a uniform mesh density. The sensitivity to imperfection as was anticipated was confirmed in the numerical results.

A literature study of the previous researches reveals that there is not much of information about the effects of imperfections on pure flexural buckling.
Nevertheless, a lot of study has been conducted on flexural -torsional buckling over the years.

2.2 Euler buckling theory

In Euler buckling, the elastic behavior of an ideal pin ended column is considered as shown in Figure 1. In this linear elastic buckling problem, the following assumptions are made [1]:

1. The material is linearly elastic and homogenous.
2. The column is initially perfectly straight and there are no other geometrical imperfections.
3. No residual stresses or other inner stresses.
4. The loading is centrically applied to the column.
5. The cross section of the column and its support conditions are such that only plane buckling in one direction is relevant.

![Figure 1: Euler Buckling [1]](image)

With reference to the lateral deformation of the column, the column will remain straight until the axial load $N$ reaches the critical buckling value, $N_{cr}$, then the column will buckle.

Now, assuming the buckling deformation at a section having a distance $x$ from $B$ to be $y$ as indicated in Figure 1, then the bending moment, $M(x)$ is expressed as:
\[ M(x) = N_{cr} \cdot y \]  \hspace{1cm} (1)

According to Euler-Bernoulli beam theory, the bending moment can be expressed as a second derivative of the deflection as:

\[ M(x) = -EI \cdot \frac{d^2y}{dx^2} \]  \hspace{1cm} (2)

where:  \( E \) is the modulus of elasticity.

\( I \) is the second moment of area.

Combining equations (1) and (2), the differential equation governing the deformations, is then expressed as:

\[-EI \cdot \frac{d^2y}{dx^2} = N_{cr} \cdot y \]  \hspace{1cm} (3)

which is rearranged to:

\[ \frac{d^2y}{dx^2} = -\frac{N_{cr}}{EI} \cdot y \]  \hspace{1cm} (4)

This differential equation (4), has the general solution as:

\[ y = A_1 \cos \left( x \cdot \frac{N_{cr}}{\sqrt{EI}} \right) + A_2 \sin \left( x \cdot \frac{N_{cr}}{\sqrt{EI}} \right) \]  \hspace{1cm} (5)

Let,

\[ w = \sqrt{\frac{N_{cr}}{EI}} \]  \hspace{1cm} (6)

Therefore, equation (5) is re-written as:

\[ y = A_1 \cos(wx) + A_2 \sin(wx) \]  \hspace{1cm} (7)

where \( A_1 \) and \( A_2 \) are constants.

The boundary conditions that apply for a pinned-pinned column are:

\[ y(0) = 0 \; ; \; y(L) = 0 \]

So,

\[ \sin(wL) = 0 \]  \hspace{1cm} (8)
Equation (8) is only satisfied when:

\[ wL = 0, \pi, 2\pi, ..., n\pi \]

Therefore:

\[ N_{cr} = \frac{\pi^2 EI}{L^2}, \quad \frac{4\pi^2 EI}{L^2}, ..., \frac{n^2\pi^2 EI}{L^2} \]

where \( n \) is any integer or reflector of buckling mode.

The lowest value of the critical buckling load, \( N_{cr} \) is:

\[ N_{cr} = \frac{\pi^2 EI}{L^2} \quad (9) \]

Equation (9) is known as the Euler buckling load which is a representation of the critical load that a column can resist to elastic buckling. It can be observed that the critical buckling load as indicated in equation (9) does not depend on the material strength. It is dependent on the dimensions of the column (i.e. the moment of area, \( I \), and the actual length, \( L \)) and the stiffness of the material, \( E \). Thus, for a given material, the critical load decreases with increased length of the column. Therefore, stocky columns will have fewer tendencies to buckle.

It is useful to control the critical load in terms of stress rather than applied force. The critical buckling load in terms of stress can be expressed as:

\[ \sigma_{cr} = \frac{N_{cr}}{A} = \frac{\pi^2 EI}{AL^2} \quad (10) \]

where: \( \sigma_{cr} \) is critical stress.

For columns, the radius of gyration, \( i \), is defined as:

\[ i = \sqrt{\frac{I}{A}} \quad (11) \]

It is a significant parameter because it is considered to indicate the stiffness of the section based on the cross section shape. Thus, the critical stress can be reformed as:

\[ \sigma_{cr} = \frac{\pi^2 E}{\left(\frac{L}{i^2}\right)} \quad (12) \]

For a more convenient and easy notation, let:
\[ \lambda = \frac{L}{l} \]  

(13)

where: \( \lambda \) is called the column slenderness ratio.

Therefore, equation (12) is re-written as:

\[ \sigma_{cr} = \frac{\pi^2 E}{\lambda^2} \]  

(14)

Equation (14), indicates that the stress of a column is inversely proportional to the square of its slenderness ratio. Figure 2 shows the relation between slenderness ratio and the critical buckling stress.

![Figure 2: Relationship described by the Euler formula between buckling stress and column slenderness [1]](image)

Steel material exhibits a well-defined yielding point. Therefore, the yielding strength, \( f_y \), is vital for steel columns. It is used to limit the maximum stress that can be allowed in the column resisting to buckle. Therefore, a column under compression can resist a maximum force given by,

\[ F_{\text{max}} = f_y \cdot A \]  

(15)

Thus, for a steel column, the stress at buckling cannot exceed the value of the yield strength. The relationship of yielding strength and strain for ideal plastic is shown in Figure 3.
Assuming the yield point is reached at the slenderness, $\lambda_r$, called the reference relative slenderness, as shown in Figure 4.

Therefore, $\lambda_r$, is obtained by letting the buckling stress be equal to the yielding strength of the steel material, which is:

$$\sigma_{cr} = \frac{\pi^2 E}{\lambda_r^2} = f_y$$  \hspace{1cm} (16)

which gives:

$$\lambda_r = \pi \cdot \sqrt{\frac{E}{f_y}}$$  \hspace{1cm} (17)

The ratio of the slenderness, $\lambda$, to the reference relative slenderness, $\lambda_r$, is known as the non-dimensional slenderness and is given by:
The failure mode change from plastic yield to elastic buckling failure occurs when \( f_y = \sigma_{cr} \) i.e. when \( \bar{\lambda} = 1 \).

2.3 Flexural buckling according to Eurocode 3

When considering resistance of members to flexural buckling, different classifications of cross-section are always considered. Eurocode 3 [10], not only presents different classes of cross-section, but also the determination of cross-sectional resistance. Classifying cross-sections may mainly depend on two critical factors:

1. The yield strength, \( f_y \), of the material, and
2. The width to thickness (c/t) ratio.

There are basically four different cross-section classes and they are defined as [10]:

"**Class 1** cross-sections are those which can form a plastic hinge with the rotation capacity required from plastic analysis without reduction of the resistance.

**Class 2** cross-sections are those which can develop their plastic moment resistance, but have limited rotation capacity because of local buckling.

**Class 3** cross-sections are those in which the stress in the extreme compression fiber of the steel member assuming an elastic distribution of stresses can reach the yield strength, but local buckling is liable to prevent development of the plastic moment resistance.

**Class 4** cross-sections are those in which local buckling will occur before the attainment of yield stress in one or more parts of the cross section."

2.3.1 Buckling resistance of members in compression

According to Eurocode 3, the ratio of the compressive force to the buckling resistance of the member may be used to verify a member in compression against buckling as:

\[
\frac{N_{Ed}}{N_{b,ld}} \leq 1.0
\]  

(19)
Where, $N_{Ed}$ is the design value of the compressive force, and $N_{b,Rd}$ is the design buckling resistance of the compression member.

Since there are about four different classes of cross-sections, it follows that the design buckling resistance of the compression member should be taken according to which cross-section class is under consideration. For cross-sections class 1, 2 and 3, the design buckling resistance is given as:

$$N_{b,Rd} = \frac{\chi A f_y}{\gamma_{M1}} \quad (20)$$

and for cross-section class 4:

$$N_{b,Rd} = \frac{\chi A_{eff} f_y}{\gamma_{M1}} \quad (21)$$

where $A$ is the cross-sectional area.

$\chi$ is the reduction factor for the relevant buckling mode.

$\gamma_{M1}$ is the partial coefficient factor for member buckling resistance.

$A_{eff}$ is the effective area of the cross-section when subjected to uniform compression.

### 2.3.2 Buckling curves

To compute the value of the reduction factor $\chi$ that appears in equation (20) and (21) above, equation (22) is utilized.

$$\chi = \frac{1}{\phi + \phi^2 - \lambda^2} \quad \text{but } \chi \leq 1.0 \quad (22)$$

where:

$$\phi = 0.5 \left[ 1 + \alpha (\bar{\lambda} - 0.2) + \bar{\lambda}^2 \right] \quad (23)$$

$\phi$ is known as the intermediate factor.

$\alpha$ is an imperfection factor.

The non-dimensional slenderness $\bar{\lambda}$ is a parameter that depends on two properties [11]. These are the geometric and material properties of a member. The material properties of a member are the modulus of elasticity, $E$ and the yield strength, $f_y$. Equation (24) and (25) gives the value of the non-dimensional slenderness $\bar{\lambda}$ for different classes of cross-sections. For cross-sections class 1, 2 and 3, it is given by:

$$\bar{\lambda} = \frac{A f_y}{N_{cr}} \quad (24)$$
and for cross-section class 4:

\[ \lambda = \frac{A_{\text{eff}} f_y}{N_{cr}} \]

(25)

As mentioned, \( N_{cr} \) is the elastic critical force for the relevant buckling mode based on the gross cross-sectional properties, which is the well-known Euler buckling load. It is a critical load without considering imperfections.

The imperfection factor \( \alpha \) that appears in equation (23) depends on [12]:

1. The cross-section shape of the column under consideration
2. The process of fabrication used
3. The direction in which buckling occurs i.e. the weak or strong axis plane of buckling
4. The yielding strength.

The imperfection factor \( \alpha \) must be chosen according to Table 1 and
Table 2

Table 1: Imperfection factor for buckling curves [12].

<table>
<thead>
<tr>
<th>Buckling curve</th>
<th>$a_0$</th>
<th>$a$</th>
<th>$b$</th>
<th>$c$</th>
<th>$d$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Imperfection factor $\alpha$</td>
<td>0.13</td>
<td>0.21</td>
<td>0.34</td>
<td>0.49</td>
<td>0.76</td>
</tr>
</tbody>
</table>

Once $\alpha$ has been carefully selected, it’s easier to get the reduction factor represented by equation (22).
Table 2. Selection of a buckling curve for a cross-section [10]

<table>
<thead>
<tr>
<th>Cross section</th>
<th>Limits</th>
<th>Buckling about axis</th>
<th>Buckling curve</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>S 235</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>S 275</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>S 355</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>S 420</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>S 460</td>
</tr>
<tr>
<td>Rolled sections</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>$t &lt; 40$ mm</td>
<td>$y - y$</td>
<td>a</td>
</tr>
<tr>
<td></td>
<td>$40 \text{ mm} &lt; t &lt; 100$ mm</td>
<td>$y - y$</td>
<td>b</td>
</tr>
<tr>
<td></td>
<td>$t \leq 100$ mm</td>
<td>$y - y$</td>
<td>b</td>
</tr>
<tr>
<td></td>
<td>$t &gt; 100$ mm</td>
<td>$y - y$</td>
<td>d</td>
</tr>
<tr>
<td>Welded I-sections</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>$t_1 \leq 40$ mm</td>
<td>$y - y$</td>
<td>b</td>
</tr>
<tr>
<td></td>
<td>$t_1 &gt; 40$ mm</td>
<td>$y - y$</td>
<td>c</td>
</tr>
<tr>
<td>Hollow sections</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>hot finished</td>
<td>any</td>
<td>a</td>
</tr>
<tr>
<td></td>
<td>cold formed</td>
<td>any</td>
<td>c</td>
</tr>
<tr>
<td>Welded box sections</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>generally (except as below)</td>
<td>any</td>
<td>b</td>
</tr>
<tr>
<td></td>
<td>thick welds: $a &gt; 0.5t_1$ $b &lt; 10$ $b/t_1 &lt; 30$</td>
<td>any</td>
<td>c</td>
</tr>
<tr>
<td>U-shape and solid sections</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>any</td>
<td></td>
<td>c</td>
</tr>
<tr>
<td>L-sections</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>any</td>
<td></td>
<td>b</td>
</tr>
</tbody>
</table>

When using Eurocode 3, the column design procedures for flexural buckling may usually consist of six main steps [11]:

1. Trial section selection. This means that the cross-section class to be considered must be chosen.

2. Determining the buckling length of the column
3. Calculate the non-dimensional slenderness, $\bar{\lambda}$

4. Pick the suitable buckling curve ($a_0, a, b, c, or d$) and the equivalent imperfection factor $\alpha$

5. Get the buckling reduction factor, $\chi$

6. Compute the design buckling resistance using equation (20) or (21)

For greater values of the non-dimensional slenderness, the influence of imperfections is small. Therefore, the resistance approaches the Euler critical value as the slenderness increase. See Figure 5 which shows the buckling curves.

![Figure 5: Buckling curves in Eurocode 3 [10]](image)

The difference between the curves in Figure 5 reflects the influence of the below factors on the buckling of the column:

1. Manufacturing processes,

2. The cross-sectional dimensions, and,

3. Weak axis about which the buckling occurs.
3. Background to flexural buckling in Eurocode 3.

Eurocode 3 presents sets of formulae according to each buckling mode under consideration. Buckling can be flexural, torsional, torsional-flexural or lateral-torsional buckling. This work focuses on the flexural buckling. Flexural buckling is the mode of buckling in which the member deflects purely along the strong or the weak axis of the column.

3.1 Derivation of the second order moment

Euler buckling theory considers an ideal straight column which, in practice, cannot be achieved because real columns are usually never perfectly straight. Geometrical imperfection as initial bow and load eccentricity along with mechanical imperfection as yielding strength and residual stresses, are present. This will affect the behavior of the columns and influence their buckling resistance.

Considering a member under axial compression, \( N \), with initial geometrical imperfections [12] as shown in Figure 6. The initial bow imperfection is assumed to be sinusoidal having the maximum value at mid-span.

![Figure 6: Simply supported member loaded with a normal force \( N \) and initial bow imperfection \( e_0 \)](image)

\[ M_o = N e_0 \]

\[ M_o = N(e_0 + y) \]

[13]
Figure 6 shows a column with initial bow imperfection, where $e_0$ is the initial deflection in the middle section. The initial deflection together with the force means that the column is subjected to an external moment $M_e$. This moment is given by [13]:

$$M_e = Ne_0$$

Where:

$N$ is the applied axial force

$e_0$ is the initial deflection in the mid-section of the column

$M_e$ is the external moment created by the initial deflection and force $N$.

The bending moment will cause further deflection $y$ in mid-length of the column consequently increasing the external bending moment which can be expressed as:

$$M_e = N(e_0 + y) \quad (26)$$

where $y$ is the additional deflection in the mid section caused by the axial force on the initially bowed column.

According to equation (26), the increase in deflection $y$ caused due to the load $N$ would cause an increase in external moment $M_e$. This increase in moment would eventually cause a further increase in deflection $y$.

When the deflection is increasing, the column resists this through an internal resistance against bending deformations. This internal moment can be expressed with the static beam theory as:

$$M_I = -EI \frac{d^2y(x)}{dx^2} \quad (27)$$

Where:

$M_I$ is the moment caused by the resistance of the column to an external force.

$E$ is the modulus of elasticity

$I$ is the moment of inertia

$y$ is the deflection

$x$ is the coordinate in the length direction of the column

By assuming that the initial deflection $e_0(x)$ and additional deflection $y(x)$ are sinusoidal:
\[ e_0(x) = e_0 \cdot \sin\left(\frac{\pi x}{L}\right) \quad (28) \]

\[ y(x) = y \cdot \sin\left(\frac{\pi x}{L}\right) \quad (29) \]

The internal moment caused by the increase in deflection \( y(x) \) can be described as:

\[ M_i = -EI \frac{d^2 \left( \sin\left(\frac{\pi x}{L}\right) \right)}{dx^2} \quad (30) \]

Therefore, the internal moment in the mid-section of the column can then be described as:

\[ M_i = EI \frac{\pi^2 y}{L^2} \quad (31) \]

For the internal resisting moment to be able to stop the increase in deflection, caused by the external moment, it must be at least as large as the external moment, i.e., rate of change of internal resisting moment must be greater than the rate of change of the external moment.

The rate of change of the external moment \( M_e \) is:

\[ \frac{dM_e}{dy} = \frac{dN(e_0(x) + y)}{dy} = N \quad (32) \]

If the rate of increasing external moment, \( M_e \), is higher than or equal to the rate of increasing internal moment \( M_i \), the column will buckle i.e. if \( N \geq EI \frac{\pi^2}{L^2} \).

However, if the load acting on the column is smaller, the column would remain stable, i.e. when \( N \leq EI \frac{\pi^2}{L^2} \). This means that for any given column, with certain geometry and material, there is a critical value on the force.

\[ N_{cr} = EI \frac{\pi^2}{L^2} \quad (33) \]

where \( N_{cr} \) is the Euler buckling load.

This will mean that for a normal force lower than the critical buckling load, it is possible to find equilibrium. This equilibrium will occur at a deformation \( y_{equ} \) where the internal moment is equal to the external moment.

\[ M_i = M_e \Rightarrow EI \frac{\pi^2}{L^2} y_{equ} = N(e_0 + y_{equ}) \quad (34) \]
Simplifying the above expression:

\[ \gamma_{equ} = \frac{N}{E I \pi^2 - N} e_0 \Rightarrow \gamma_{equ} = \frac{N}{N_{cr} - N} e_0 \]  

(35)

Thus the total deflection at equilibrium position is:

\[ (e_0 + \gamma_{equ}) = e_0 + \frac{N}{N_{cr} - N} e_0 \Rightarrow \frac{N_{cr}}{N_{cr} - N} e_0 \]  

(36)

Equation (36) is called as second order deflection.

The deflection gives the following external moment:

\[ M_e = N \left( \frac{N_{cr}}{N_{cr} - N} e_0 \right) \]  

(37)

Equation (37) is called as second order moment.

3.2 Reduction factor

The derivation of the reduction factor, \( \chi \), for a simple case can be made from second-order analysis done above. Consider the illustration as shown in Figure 7 of a simply supported member under pure axial compression with an initial transverse deflection [14].

\[ y_0(x) = e_0 \sin \left( \frac{\pi x}{L} \right) \]  

(38)

Assuming a sinusoidal deflection, the initial geometrical imperfection can be expressed as:

When an axial force \( N \) is applied to the column, the additional deflection associated to instability can be expressed as:

\[ y(x) = A \sin \left( \frac{\pi x}{L} \right) \]  

(39)
The classical buckling equilibrium equation for this case then is:

\[ y'' + \frac{N}{EI} (y_0(x)) + y(x) = 0 \]  

(40)

Inserting equations (38) and (39) into equation (40) and evaluating:

\[ A = \frac{N}{N_{cr} - N} e_0 \]  

(41)

where: \( N_{cr} \) is the elastic buckling load i.e. the Euler load.

Thus, equation (39) is re-written as:

\[ y(x) = \frac{N}{N_{cr} - N} e_0 \sin \left( \frac{\pi x}{L} \right) \]  

(42)

At mid span, the total deflection is expressed as:

\[ y_{max} = \frac{N}{N_{cr} - N} e_0 \]  

(43)

The member cross-section’s resistance criterion at mid-span including second order effects is then expressed as:

\[ \frac{N}{A f_y} + \frac{1}{1 - \frac{N}{N_{cr}}} \cdot \frac{N \cdot e_0}{M_{ed}} \leq 1 \]  

(44)

where: \( M_{ed} \) is the bending moment.

Let,

\[ A f_y = N_{Rd} \]  

(45)

where: \( N_{Rd} \) is the design values of resistance to normal forces.

The buckling resistance, \( N_{b,Rd} \), is expressed as:

\[ N_{b,Rd} = \chi \cdot N_{Rd} \]  

(46)

where: \( \chi \) is called the reduction factor.

\( N_{b,Rd} \) is the design buckling resistance

From Equation (18), the relation for Non-dimensional slenderness can be rewritten as:
The bending moment is the product of the yield force and elastic modulus, \( W_{el} \), and is expressed as:

\[
M_{ed} = W_{el} \cdot f_y
\]  

(48)

Where: \( M_{ed} \) is called the design bending moment.

At buckling, the maximum applied axial force reaches the actual buckling resistance, thus:

\[
N = N_{b,Rd} = \chi \cdot N_{Rd}
\]  

(49)

Inserting equations (45), (46), (47), (48) and (49) into equation (44), then:

\[
\frac{\chi N_{Rd}^2}{N_{Rd}^2} + \frac{1}{1 - \chi} \frac{N_{Rd} e_0}{W_{el} f_y} \leq 1
\]

\[
\chi + \frac{1}{1 - \chi} \frac{\chi A f_y e_0}{W_{el} f_y} \leq 1
\]

\[
\chi + \frac{1}{1 - \chi} \frac{\chi A e_0}{W_{el}} \leq 1
\]  

(50)

Solving for \( \chi \) in equation (50)

Let,

\[
\frac{A \cdot e_0}{W_{el}} = \eta
\]  

(51)

Thus,

\[
\chi + \frac{1}{1 - \chi} \cdot \eta \chi = 1
\]

After rearrangement, a second order of polynomial is obtained as:

\[
\chi^2 - (1 + \eta + \lambda^2) \chi + 1 = 0
\]  

(52)

Solving the quadratic equation (52) will give out two solutions. The lower value is taken to be the reduction factor, therefore:

\[
\chi = \frac{(1 + \eta + \lambda^2) - \sqrt{(1 + \eta + \lambda^2)^2 - 4\lambda^2}}{2\lambda^2}
\]  

(53)
Let,

\[ 0.5(1 + \eta + \bar{\lambda}^2) = \Phi \]

Therefore:

\[ \chi = \frac{\Phi - \sqrt{\Phi^2 - \bar{\lambda}^2}}{\bar{\lambda}^2} \quad (54) \]

Pre-multiplying equation (55) with \( \Phi + \sqrt{\Phi^2 - \bar{\lambda}^2} \), thus:

\[ \chi = \frac{1}{\left( \Phi + \sqrt{\Phi^2 - \bar{\lambda}^2} \right)} \quad (55) \]

Equation (55) is the reduction factor which is identical to equation (22) given in Eurocode 3.

The basis to the buckling curves in Eurocode 3 as shown in Figure 8 was based on an extensive measurement campaign in 1973 on columns to find out their buckling behaviors [15].

More than 1000 buckling tests on I, H, T, U, circular and square hollow sections with slenderness between 55 to 160 were studied. During these experiments, the imperfections taken into account were the residual stresses (considered according to the manufacturing process and the cross-section) and an initial out of straightness of the order 1/1000th the length of the column at the centre point.

These initial out of straightness was calibrated to reproduce the effects of all the other imperfections found in a column. This is also rightly called the 'Equivalent initial deformed configuration'.

The values of all the experiments plotted were compared to the Euler’s buckling curve as shown in Figure 8.
According to Figure 9, the columns are classified into three major categories as follows:

a) Columns with large slenderness

These are columns that lie towards the right of the point of inflexion. The buckling loads for these columns are similar to the Euler buckling load \( N_{cr} \). Imperfections do not play much of a role in the buckling of these columns as the buckling of these columns occur in the elastic range.
b) Columns with medium slenderness

These are columns that deviate the maximum from the Euler's theory.

At buckling, some of the fibers have already reached yield strength. Hence the effective area that resists buckling at a point before buckling is less than the actual cross-sectional area of the column.

Hence, the presence of imperfections greatly affects the load bearing capacity of these columns.

c) Columns with low slenderness

These columns are also called as stocky columns. Its buckling resistances are very high as they are short and its load bearing capacity is mainly governed by the yield strength.
4. Case Study—Investigation of the influence of imperfections.

Alstom in Växjö, Sweden, deals with air pollution control equipment. In Växjö, Alstom provides service for Växjö Energi AB (VEAB), which is a thermal power plant. Alstom does this by maintaining the flue gas lines at VEAB. One of the key pollution control equipments in the flue gas line is the Electro-Static precipitator (ESP). This equipment separates the suspended particles in the exhaust gases. It typically collects 99.9% of the suspended particles. The size of the equipment can be visualized to be the size of a 10 or 12 storey building.

In this case study, a steel structure that supports the ESP was considered. Figure 10 shows the support structure in ABAQUS 6.14. One of the columns of this structure was used as a specimen to study the effect of imperfections on the buckling resistance capacity. The structure contains 6 main columns and a network of cross-bracing which are connected together by pin joints. The main columns were standard hot-rolled with a profile of HEA 300 and the material is steel S355J2.

Figure 10: The model of the complete structure.
Table 3 shows material data and profiles.

<table>
<thead>
<tr>
<th>Material</th>
<th>Density, [kg/m³]</th>
<th>Modulus of Elasticity, [MPa]</th>
<th>Poisson’s ratio,</th>
<th>Yield Strength [MPa]</th>
<th>Ultimate Strength [MPa]</th>
</tr>
</thead>
<tbody>
<tr>
<td>S355J2</td>
<td>7850</td>
<td>210000</td>
<td>0.30</td>
<td>355 ( t_f \leq 16) mm</td>
<td>470 ( t_f \leq 16) mm</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>355 ( 16 \leq t_f \leq 40) mm</td>
<td>470 ( 16 \leq t_f \leq 40) mm</td>
</tr>
</tbody>
</table>

The material profiles in Table 3 were used in the modeling of a column in ABAQUS.

The length of the main columns was 9.169 meters. However, the columns have cross-bracings at 4.597 meters from the bottom indicated by L in Figure 10. To facilitate the study of the load on the column alone and considering the effect of the cross bracing, the 4.597 meters length was considered for the study.

4.1 Flexural buckling resistance according to Eurocode 3

Critical in the design of steel structures are the design loads that the structure will be subjected to. Table 4 shows the loads that the columns A, B and C will be subjected to. These loads form the basis for the calculation of the design loads for each column.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>D1, D2</td>
<td>364</td>
<td>38</td>
<td>378</td>
</tr>
<tr>
<td>J1, J2</td>
<td>375</td>
<td>63</td>
<td>624</td>
</tr>
<tr>
<td>K1, K2</td>
<td>239</td>
<td>38</td>
<td>312</td>
</tr>
</tbody>
</table>

4.1.1 Cross section classification

The coefficient of the yield strength of the cross section under consideration is given as,

\[ \varepsilon = \frac{235}{f_y} \]  \( \text{(56)} \)

\( f_y \) being the yield strength. It should be noted here that, in Eurocode 3, the definition of \( \varepsilon \) employs the base value of 235 \( N/mm^2 \). This is because
grade S235 steel is highly regarded as the normal grade throughout Europe [17]. Thus, $\epsilon = \sqrt{\frac{235}{355}} = 0.8136$.

To get the class of the cross section, the class of the flange and of the web must be determined independently because they have different thicknesses. Figure 11 shows the cross-sectional dimensions for HEA 300 columns.

![Figure 11: Cross-section dimensions of a HEA 300 column. All dimensions in mm [18]](image)

where, $t_w$ is the thickness of the web and $t_f$ is the thickness of the flange.

Thus, for the flange, the width, $c$, is given by [17]:

$$c = \frac{b - t_w - 2R}{2}$$

$$c = \frac{300 - 8.5 - (2 \times 27)}{2} = 118.75 \text{ mm}$$

$$\frac{c}{t_f} = \frac{118.75}{14} = 8.4821$$

The limit for cross-section class 2 flange: $10\epsilon = 8.1362$ [17]. Therefore, the flange is class 3 since $\frac{c}{t_f} > 8.1362$.

For the web, the width is given by:

$$c = h - 2t_f - 2R$$

$$c = 290 - (2 \times 14) - (2 \times 27) = 208 \text{ mm}$$
The limit for cross-section class 1 web: \(33\varepsilon = 26.8493\) [17]. Thus, the web is class 1.

The overall cross-section classification is therefore class 3.

4.1.2 Euler buckling load and non-dimensional slenderness

The available data is:

\[ E = 210\text{GPa} \]
\[ l = 6.31 \times 10^{-5} m^4 \]
\[ L = 4.597 m \]
\[ A = 0.0112 m^2 \]

Therefore, the Euler buckling load,

\[ N_{cr} = \frac{\pi^2El}{L^2} = \frac{\pi^2 \times 210 \times 10^9 \times 6.31 \times 10^{-5}}{4.597^2} = 6.1887 \times 10^6 N \]

The non-dimensional slenderness is given as:

\[ \bar{\lambda} = \sqrt{\frac{Afy}{N_{cr}}} = \sqrt{\frac{0.0112 \times 355.10^6}{6.1887 \times 10^6}} = \sqrt{0.6453} = 0.8033 \]

4.1.3 Determination of buckling curve and imperfection factor

The Design loads, \(N_{Ed}\), for the columns are calculated as follows:

\[ N_{Ed} = (1.35 \times \text{Dead}) + (1.5 \times \text{Dust}) + (1.05 \times \text{Live}) \quad (59) \]

where 1.35, 1.5 and 1.05 in equation (59) are recommended set of partial safety factors provided by Eurocode for transient design situations where there is a risk of loss of static equilibrium [19].

for columns \(A_1, A_2, N_{EdA} = (1.35 \times 364) + (1.5 \times 378) + (1.05 \times 38) = 1098.3 KN \)

for columns \(B_1, B_2, N_{EdB} = (1.35 \times 375) + (1.5 \times 624) + (1.05 \times 63) = 1508.4 KN \)
for columns $C_1, C_2$, $N_{Edc} = (1.35 \times 239) + (1.5 \times 312) + (1.05 \times 38) = 830.55\, KN$

To help in selecting the buckling curve to be used, the detailed data of the cross-section as given in Table 5 [20] can be used.

**Table 5: Cross-section data**

<table>
<thead>
<tr>
<th>$h/b$</th>
<th>Radius of gyration $[mm]$</th>
<th>Moment of inertia $[mm^4]$</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.9667</td>
<td>$i_y = 127.4$</td>
<td>$I_y = 18265 \times 10^4$</td>
</tr>
<tr>
<td></td>
<td>$i_z = 74.9$</td>
<td>$I_z = 6310 \times 10^4$</td>
</tr>
</tbody>
</table>

From Figure 11 $h/b < 1.2$, and since flexural buckling is about the weak axis, and from the moment of inertia above, $Z$-axis is the weak axis, and $t_f < 100\, mm$, the buckling curve $c$ is considered, see
Table 2. The imperfection factor for this buckling curve, $\alpha = 0.49$, from Table 1.

4.1.4 Calculation of the reduction factor

The available data is:

$\alpha = 0.49$

Thus, the intermediate factor is given as:

$\phi = 0.5[1 + \alpha(\bar{\lambda} - 0.2) + \bar{\lambda}^2]$

$\phi = 0.5[1 + 0.49(0.8033 - 0.2) + 0.6453]$

$\phi = 0.9705$

and the reduction factor is:

$$\chi = \frac{1}{\phi + \sqrt{\phi^2 - \bar{\lambda}^2}} = \frac{1}{0.9705 + \sqrt{0.9705^2 - 0.8033^2}}$$

$\chi \approx 0.66$

and the buckling resistance is:

$$N_{b,Rd} = \frac{\chi A f_y}{\gamma_{M1}} = \frac{0.66 \times 0.0112 \times 355.10^6}{1} = 2.6359 \times 10^6 N$$

where: $\gamma_{M1}$ is the partial safety factor

4.1.5 Buckling resistance

A compression member, according to Eurocode 3, should be verified against buckling using equation (19):

$$\frac{N_{Ed}}{N_{b,Rd}} \leq 1.0$$

The column experiencing the highest load must be checked against this criterion. Columns $B_1, B_2$ have the highest load, thus:

$$\frac{N_{Ed}}{N_{b,Rd}} = \frac{1508.4 \times 10^3}{2.636 \times 10^6} = 0.5722$$

Hence, the criterion is fulfilled. This means that the other columns experiencing the lowest load than columns $B_1, B_2$ will also fulfill the criteria.
4.1.6 Buckling effects

According to Eurocode 3, the buckling effects may be ignored for:

i. \( \bar{\lambda} \leq 0.2 \)

ii. \( \frac{N_{Ed}}{N_{cr}} \leq 0.04 \)

The columns are HEA300 and the slenderness is 0.8033. Since 0.8033 > 0.2, it means that the effect of buckling cannot be ignored. However, this check is not enough because the columns are subjected to different values of the design compression load, \( N_{Ed} \). The column experiencing the lowest load must be checked against the second equation above. Therefore, for columns \( C_1, C_2, \)

\[
\frac{N_{Ed}}{N_{cr}} = \frac{830.55 \times 10^3}{6.1887 \times 10^6} = 0.1342
\]

Since 0.1342 > 0.04, the buckling effects cannot be ignored. This means that the columns with the higher loads than columns \( C_1, C_2, \) the buckling effects cannot be ignored either.

4.1.7 Initial local bow imperfection, \( e_0 \)

The values of the initial bow imperfection for each buckling curve are given in Table 6. These are reference values as provided in Eurocode 3. These values take into account all kinds of imperfections.

<table>
<thead>
<tr>
<th>Buckling curves</th>
<th>Elastic analysis</th>
<th>Plastic analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>( a_0 )</td>
<td>( \frac{1}{350} )</td>
<td>( \frac{1}{300} )</td>
</tr>
<tr>
<td>( a )</td>
<td>( \frac{1}{300} )</td>
<td>( \frac{1}{250} )</td>
</tr>
<tr>
<td>( b )</td>
<td>( \frac{1}{250} )</td>
<td>( \frac{1}{200} )</td>
</tr>
<tr>
<td>( c )</td>
<td>( \frac{1}{200} )</td>
<td>( \frac{1}{150} )</td>
</tr>
<tr>
<td>( d )</td>
<td>( \frac{1}{150} )</td>
<td>( \frac{1}{100} )</td>
</tr>
</tbody>
</table>

From Table 6, the column in study for which buckling curve \( c \) is chosen, plastic analysis is considered,
thus, \( e_0 = \frac{4597}{150} = 30.647\ mm \)

Plastic analysis is the analysis in which the inelastic material is studied beyond the elastic limit. On the other hand, elastic analysis is the analysis in which the material is studied within the region where the stress is proportional to the strain i.e. the elastic region.

4.2 Finite Element modeling

ABAQUS 6.14 software was utilized for the finite element modeling of the column. Only one column was selected for the analysis. The software was used to perform the buckling and post-buckling analyses of the HEA 300 steel column. The column was modeled as a 3D extruded solid. The detailed modeling procedures are presented in appendix 1 of this thesis.

In the case of any structure that is being analyzed, the member experiencing the highest load would define the integrity of the structure. Hence, in this case, the columns \( B_1 \) and \( B_2 \) as shown in Figure 10 would be the ones that buckle first as it experiences the highest load. Therefore, one of columns B was chosen for the analysis.

4.2.1 Boundary conditions

To be able to get a clear and meaningful comparison between numerical and experimental results, it is important to ensure that the boundary conditions are adequately and properly modeled [23]. The column was modeled as a pinned-pinned support condition. Therefore, the boundary conditions considered for the analysis were that the column was pinned on both ends. The pinned-pinned boundary conditions in this work were modeled in such a way that the bottom and top ends were free to rotate about the axes. However, no translation was allowed in any direction at the bottom end of the model. At the top end, where the load was applied, no translation was allowed in the \( x \) and \( y \) directions. Translation was allowed in the \( z \) direction because this was the axis along which the load was applied. The load, for both the linear buckling and non-linear buckling analyses, was applied along the \( z \)-axis as shown in Figure 12 by the red arrow. The surface where the load was applied was considered the top surface.
Before the application of the load, both the end faces of the columns were made rigid to prevent an indent caused by a concentrated point load on the faces. In order to achieve this, two reference points were created at the center of the cross-sections at both ends. Both surfaces were kinematically coupled to the reference points in all six degrees-of-freedom.

4.2.2 Material modeling

The HEA300 steel column in this work was modeled as homogeneous and isotropic. This column was modeled considering linear elasticity and elasticity-plasticity. The Young’s modulus, $E$, and the Poisson’s ratio, $\nu$, gives the full characteristics of a linear elastic behavior [23]. Implementation of the elastic-plastic behavior in ABAQUS is easy and straightforward. Everything is incorporated in the ABAQUS material behavior library. Implementation simply involves providing the true stress and true strain in plasticity properties in the material library [24] [25].

4.2.3 True stress and true strain

Using the Young’s modulus, yield strength and ultimate strength, the material plastic behavior of the steel column were determined. In ABAQUS software, for the non-linear analysis, presented in section 4.2.5, the plastic characteristics of the material need to be taken into consideration.

The true strain or the logarithmic strain is a mathematical model which describes the plastic behavior of the metals which accounts for differences in the compression and tensile behavior independent of the structure's geometry or nature of the load applied. [24]
In ABAQUS, when plasticity of the material data is defined, true stress and true strain should be used. These are the values that ABAQUS need to correctly interpret the data. The nominal stress and strain values are often supplied by the material test data. However, the material plasticity data must be converted from the nominal stress and nominal strain values to the true stress and true strain values respectively [24] [25].

The plastic properties are computed using the following relationships [25]:

\[ \sigma_{\text{true}} = \sigma (1 + \varepsilon) \]  
\[ \varepsilon_{\text{true}} = \ln(1 + \varepsilon) \]

where \( \varepsilon \) is nominal strain

\( \sigma \) is nominal stress

\( \sigma_{\text{true}} \) is the true stress

\( \varepsilon_{\text{true}} \) is the true strain

Figure 13 shows the nominal stress-strain curves, for an elastic material and for the elastic-plastic material, which were utilized to calculate the values of the true stresses and true strains

![Figure 13: Nominal stress-strain curves, where a) is for purely elastic material and b) is for elastic-plastic material [25]](image)

To calculate the strain the values of the yield strength and ultimate strength from Table 3 are used, thus:

From Figure 13a, since the slope is \( E \) [25], for the elastic region, thus,

\[ (355 \times 10^6 - 0) = E \times (\varepsilon_1 - 0) \]

Therefore: \( \varepsilon_1 = \frac{355 \times 10^6}{210 \times 10^9} = 0.0016 \)
For the plastic region, the slope is $E/100$. See Figure 13b. Thus,

$$(470 \times 10^6 - 355 \times 10^6) = [E/100] \times (\epsilon_2 - \epsilon_1)$$

Therefore: $\epsilon_2 = \frac{100 \times 115 \times 10^6}{210 \times 10^9} + 0.0016 = 0.0565$

Utilizing equation (59) and (60), the true yield strength is:

$$\sigma_{ytrue} = \sigma_y(1 + \epsilon_1)$$

$$\sigma_{ytrue} = 355 \times 10^6(1 + 0.0016) = 355.6001 \text{ MPa}$$

and the true ultimate strength is:

$$\sigma_{uttrue} = \sigma_u(1 + \epsilon_2)$$

$$\sigma_{uttrue} = 470 \times 10^6(1 + 0.0565) = 496.5644 \text{ MPa}$$

Table 7 show the summary of the values calculated.

<table>
<thead>
<tr>
<th>Nominal Strain</th>
<th>Engineering Stress [Mpa]</th>
<th>True Strain</th>
<th>True Stress [Mpa]</th>
<th>Strain for non linear analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 0.0016</td>
<td>355</td>
<td>0.0016</td>
<td>355.6001</td>
<td>0</td>
</tr>
<tr>
<td>2 0.0564</td>
<td>470</td>
<td>0.0549</td>
<td>496.5644</td>
<td>0.0525</td>
</tr>
</tbody>
</table>

The values in the last column of Table 7 were used for the non-linear analysis in this thesis.

4.2.4 Mesh and element

In finite element analysis, to obtain accurate results, the mesh refinement levels must be good enough. In this work, the linear hexahedral element was used. The element size mesh along the length was taken to be 50mm while along the cross section, the element size was fine-tuned in proximity to result in equal and uniform elements by seeding the edges. Figure 14 shows the mesh of the entire column and an enlarged view of the mesh on and around the cross section.
4.2.5 Linear buckling analysis

The linear buckling analysis requires solving an Eigen-value problem defined by the column geometric matrices and elastic stiffness. ABAQUS obtains the solution through the sub-space iteration method. In this work, the linear buckling analysis was performed to obtain the mode shapes and the corresponding Eigen-values. The analysis was done by selecting the linear perturbation buckle step in ABAQUS and selecting the number of modes. 5 modes were chosen in this study. Flexural buckling occurred as the third mode shape. The displacements of the modes were saved in a node file by modifying the Keywords of the model. The Eigen-value and mode shape of the third mode were used as the reference load and initial bow imperfection in the non-linear buckling analysis will be presented in section 4.2.6.

4.2.6 Non-linear buckling analysis

After the linear buckling analysis was performed the non-linear buckling analysis, also known as the post-buckling analysis, was conducted to determine the ultimate loads. In this work, the non-linear buckling analysis was performed by employing the Riks method, also known as the arc-length control strategy. ABAQUS implements this with predefined increment and tolerance parameter. In this work, the number of increments was set to be 30.
In this analysis, the mode shape of the elastic flexural buckling shape (i.e. the third mode from linear buckling analysis) was entered into the model as the initial bow imperfections by utilizing the edit Keywords of the model. Four different magnitudes of initial bow imperfections were studied. Two of the initial bow imperfections studied was \( \frac{L}{1000} \) and \( \frac{L}{1500} \) which provide the maximum and minimum tolerance values according to [26]. The other initial bow imperfection studied was arbitrarily chosen as \( \frac{L}{1200} \).

While, the equivalent initial bow imperfection of \( \frac{L}{150} \) provided by Eurocode 3 for curve c was studied as well to verify how well the modified initial bow represents all kinds of initial imperfections found in real columns.

Besides, an initial bow imperfection of \( 1.5 \frac{L}{1000} \) observed to be the maximum value, allowed by this manufacturer of steel in Sweden, Broderna Edstrand AB [27] was also considered. This initial bow imperfection would represent the worst case scenario.

4.2.6.1 Initial bow imperfection

The initial bow imperfection can be incorporated in the model either manually through ABAQUS script or automatically by defining a linear combination of buckling mode shapes by editing the Keywords of the model [23]. These mode shapes are from the preliminary linear buckling analysis.

In this work, the initial bow imperfections were included by editing the Keywords. Mode 3 was the critical buckling shape because this is the mode at which the column first experiences flexural buckling and has the most significant influence on the buckling load.

4.2.6.2 Residual stresses

Residual stresses exist in structural steel members. These residual stresses are induced in the steel member during the process of manufacturing, fabrication or refinement by the non-uniform temperature distribution. Usually, residual stresses are expressed as a fraction of the yield strength. However, the two may not be directly related [6]. Nevertheless, the presence of residual stress may impair significantly the stiffness of the compression member thus influence the buckling capacity and often shorten fatigue life of steel members under periodic or dynamic load [28].

In this work, residual stresses were incorporated in the FE model using the reference values shown in Figure 15.
The residual stresses were incorporated in the model to study how much
effect they have on buckling and buckling resistance.

Introducing stresses into the ABAQUS model, sets of elements to assign the
residual stresses values were created. Then the values for the residual
stresses were assigned using the 'Predefined Field' option found in the model
tree in ABAQUS. Appendix 1 explains in details this procedure.
5. Results and analysis

This chapter shows the results that were obtained in the FE simulation and the analysis based on them.

5.1 Linear buckling analysis

The buckling load in the linear buckling analysis was found to be $6.1342 \times 10^6 \, N$ and was observed at mode 3 at which the flexural buckling occurs. Figure 16 shows mode 3 of the buckled mode shape of the column.

![Figure 16: The flexural buckling mode shape of the steel column obtained from the linear buckling analysis](image)

The buckling load of $6.1342 \times 10^6 \, N$ obtained in the linear buckling analysis is close to the theoretical one of $6.1887 \times 10^6 \, N$ calculated in section 4.1.2 in this thesis.

5.2 Convergence study on the linear buckling analysis

A convergence study based on linear buckling was conducted in this work. The study was conducted on linear element type mesh with element size of 12.5mm, 25mm and 50mm along the length.

The buckling load for a 12.5mm element size linear element type mesh was $6.1328 \times 10^6 \, N$, the buckling load for a 25mm element size linear element type mesh was $6.1330 \times 10^6 \, N$, while the buckling load for a 50mm element size linear element type mesh was $6.1342 \times 10^6 \, N$.

Figure 17 shows the results from the convergence study.
From Figure 17, it can be clearly seen that the results are converging. Though the results from each element size would be similar, the 12.5 element size would be better. However, in this thesis, the 50mm element size was used due to computational time.

5.3 Non-linear buckling analysis

5.3.1 Initial bow imperfections

From the non-linear buckling analysis, the buckling resistances, for the three initial bow imperfections studied, were:

i. \( \frac{L}{1000} \)

Buckling resistance, \( N_{b,Rd} = LPF \times Elastic\ buckling\ load \)

Figure 18 shows the Load Proportionality Factor (LPF) curve which was obtained for this initial bow imperfection.
Therefore, the buckling resistance, $N_{b,rd} = 0.5472 \times 6.1342 \times 10^6$

$$= 3.3566 \times 10^6 \, N$$

Similarly, for each and every initial bow presented below, the LPF graphs were generated and the highest point on the curve was selected and multiplied with the buckling load to get the buckling resistance.

\textbf{ii.} $\frac{L}{1200}$

For this initial bow imperfection

Buckling resistance, $N_{b,rd} = 0.5595 \times 6.1342 \times 10^6$

$$= 3.4321 \times 10^6 \, N$$

\textbf{iii.} $\frac{L}{1500}$

For this initial bow imperfection,

Buckling resistance, $N_{b,rd} = 0.5735 \times 6.1342 \times 10^6$

$$= 3.5179 \times 10^6 \, N$$
In order to evaluate the accuracy of the model that has been used for the analysis, the initial bow imperfection ratio of \( \frac{L}{150} \) has been studied:

iv. \( \frac{L}{150} \)

For this initial bow imperfection,

\[
\text{Buckling resistance, } N_{b,rd} = 0.3681 \times 6.1342 \times 10^6 \]
\[
= 2.2580 \times 10^6 N
\]

Since the initial bow imperfection of \( \frac{1.5L}{1000} \) represents the worst case scenario of a column, it's buckling resistance has also been analyzed.

v. \( \frac{1.5L}{1000} \)

For this initial bow imperfection,

\[
\text{Buckling resistance, } N_{b,rd} = 0.5161 \times 6.1342 \times 10^6 \]
\[
= 3.1658 \times 10^6 N
\]

Figure 19 shows the load-displacement curves for all the five initial bow imperfections that were studied.
5.3.2 Residual stresses

Figure 20 shows the residual stress distribution on the flange input in ABAQUS.

![Figure 20: Input of the residual stress distribution on the flange of the model](image)

Figure 21 shows the residual stress distribution on the web.

![Figure 21: Input of the residual stress distribution on the web of the model](image)

The presence of residual stresses will result in early partial yielding in the cross-section. The partial yielding will decrease the effective area on the cross section and therefore reduce the buckling resistance of the column.

Considering only residual stress,

\[
N_{b,Rd} = 0.6810 \times 6.1342 \times 10^6
\]

\[
= 4.1779 \times 10^6 N
\]

Inferring from the results obtained, the effect of residual stress alone is about 32% of the Euler buckling load.
5.3.3 Combined residual stresses and initial bow imperfections

Since $\frac{L}{1000}$ gives the least buckling resistance concerning hot rolled sections, it is picked to study the combined effects of the initial bow imperfections and the residual stresses.

Therefore, the buckling resistance, $N_{b,Rd} = 0.5466 \times 6.13417 \times 10^6$

$$= 3.3529 \times 10^6 N$$

Taking both the initial bow imperfection and residual stress into account, the buckling resistance of $3.3529 \times 10^6 N$ from the simulation, as calculated above, is significantly higher than $2.636 \times 10^6 N$ that was theoretically calculated according to Eurocode 3. Thus, the effect of the combined residual stresses and initial bow imperfection is about 45.3% of the Euler buckling load.

Since $\frac{1.5L}{1000}$ represents the worst-case scenario of any column supplied by Broderna Edstrand AB, it is also considered to study the combined effect.

Therefore, the buckling resistance, $N_{b,Rd} = 0.5123 \times 6.1342 \times 10^6$

$$= 3.1425 \times 10^6 N$$

Thus, it is observed that in the worst case, a column would buckle at 51.2% of the Euler buckling load considering the effects of the both the initial bow imperfections and residual stresses.
6. Comparison of buckling curve c in Eurocode 3 and established from simulation.

To establish the buckling curve from simulation, two separate models were simulated with different non-dimensional slenderness ratios. Following the same procedure, firstly the linear buckling analysis was done on each model to get the buckling load. Thereafter, the non-linear buckling analysis was conducted incorporating both the initial bow and residual stresses.

6.1 Model with non-dimensional slenderness value of 1.2

The length of the column for this value of non-dimensional slenderness was 6.867 m. $\frac{L}{1000}$ initial bow imperfection is used because it has been selected for the analysis. The non-linear buckling analysis is then performed to get the LPF curves in the same way as described in section 5.3.

Thus, buckling resistance, $N_{b,Rd} = 0.8020 \times 2.76236 \times 10^6$

$$= 2.2154 \times 10^6 N$$

and the reduction factor is calculated by rearranging equation (20) as,

$$\chi = \frac{N_{b,Rd}}{A \cdot f_y} = \frac{2.2154 \times 10^6}{0.01125 \times 355 \times 10^6} = 0.55$$

6.2 Model with non-dimensional slenderness value of 2

The length of the column for this value of non-dimensional slenderness was 11.445 m. The same ratio of $\frac{L}{1000}$ initial bow imperfection was used here as well and the analysis done in the same manner as in section 6.1.

Thus, buckling resistance, $N_{b,Rd} = 0.9148 \times 9.96618 \times 10^5$

$$= 9.1171 \times 10^5 N$$

and the reduction factor is:

$$\chi = \frac{N_{b,Rd}}{A \cdot f_y} = \frac{9.1171 \times 10^5}{0.01125 \times 355 \times 10^6} = 0.23$$

From Eurocode 3, the non-dimensional slenderness of 0.2 and 3 corresponds to the reduction factor of 1 and 0.1 respectively. Combining the values from the simulations and the calculated values from section 4.1, the curve shown in Figure 22 was generated.
The buckling curve shown in Figure 22 gives higher reduction factor and shows almost similar trend in comparison to the buckling curve c in Figure 5 from Eurocode 3.
7. Discussion

The boundary conditions of the structure must be well defined. Wrong boundary conditions will give wrong results and will greatly affect the analysis. In this work, a pinned-pinned boundary condition was used. This means the boundary conditions used in this work were close to reality.

Meshing plays a critical role in the finite element modeling. Efforts were made to pick a mesh that gave equal and uniform elements, see Figure 14.

The value of the buckling load obtained in the linear buckling analysis was closer to the one calculated according to Eurocode 3. Moreover, the buckling resistance obtained from the analysis considering the ratio of $L/\alpha_{150}$ is close to the value from the calculations according to Eurocode 3. This confirms that the meshing done for this study was accurate enough.

The buckling resistance obtained from the Riks method considering the residual stress alone was much higher than the one calculated according to Eurocode 3. The effect of residual stress alone is about 32% of the Euler buckling load. Hence, it is observed to be higher than the 25% mentioned for the steel angles as per the literature study. This difference could be due to the one or a combination of the following reasons concerning this thesis:

- Difference in the cross-section and its area.
- Limitation in accuracy of the result due to the 50mm element size considered in this thesis.
- The reference value for the residual stresses considered in this study could be on the higher side.

Similarly, the non-linear buckling analysis, considering only initial bow imperfection was higher than the one calculated using the formula from Eurocode 3. This is because Eurocode 3 formula considers all imperfections. Nevertheless, the influence of the combined imperfections (residual stress and initial bow) was about 45.3% of the Euler buckling load. While the value depicted by the worst-case scenario for the combined effect is 51.2% of the Euler buckling load.
8. Conclusions

The linear Eigen-value buckling analysis is used to determine the critical buckling load. Elastic-plastic behavior and imperfections are not considered in this analysis. However, imperfections are always present in structures. Thus, post-buckling analysis, also known as non-linear buckling analysis, must be performed always. The elastic-plastic material and imperfections are considered in the non-linear buckling analysis.

From the results obtained in this work, the following conclusions are drawn:

- The buckling formulae in Eurocode 3 are based on second order moment and extensive experimentations on real columns.
- Imperfections are well handled by the formulae and buckling curves in Eurocode 3.
- Post-buckling analysis utilizing the Riks method in ABAQUS is an efficient way to evaluate the effects due to initial imperfections on a structure.
- The influence of residual stresses, with a magnitude of maximum about 13% in the flange and 35% in the web, of the yielding strength, on flexural buckling is about 31.90% of the design Euler buckling load.
- The effect of initial bow imperfection with a magnitude of 0.1% of the column length on flexural buckling is about 45.28% of the Euler buckling load.
- The combined effect of residual stress (magnitude as mentioned above) and initial bow imperfection (0.1% of the column length) on flexural buckling is about 45.34% of the design Euler buckling load.
- While considering the worst-case scenario, the effect of the initial bow of 0.15% of the length of the column and the combined effect were found to be 48.39% and 48.77% of the Euler buckling load respectively.
- Residual stresses influence buckling behavior. However, the influence is small compared to that of the initial bow imperfection.
Reference


[15] L. S. da Silva, R. Simões och H. Gervásio, Design of Steel Structures:


Appendix

Appendix 1: Modeling procedures
APPENDIX 1: Modeling procedures

1. Open a new ABAQUS file.

2. Create new part:

   Under ⇔ Model-1 ⇔ Double click on ☮ Parts

   The following window opens:

   ![Create Part Window]

   Assign the name ‘Column’ ⇒ Select 3D⇒Deformable⇒Solid⇒Extrusion⇒assign Approximate size to 1 ⇒ Continue.

3. Sketch the cross-section:

   In the following window sketch the shape of the cross-section of an HEA 300 beam using the create line: Connected option. Then dimension it using the Add dimension option and constrain it accordingly using the constraints option. The required sketch is shown below.
4. **Extrude the sketch:**

   click **Done** → Enter the length of the column that we need to extrude → **OK**.

5. **Create radius:**

   Next using the option, create a radius in the extruded part. Select the edges by holding down shift. → **Done** → Enter the values according to the HEA 300 standards. (0.027) → press enter.
6. **Creating datum planes:**

Using [create datum planes] create datum planes at the center of the flange by selecting 3 points in the center of the flange. Using [create a datum plane] create a datum plane along the line where the radius merges with the web. The desired result is shown below:

![Datum Planes Diagram]

7. **Partitioning the Model:**

Using [create a partition] Sketch origin: Auto Calculate select the one of the end faces as shown below:

![Partitioned Model Diagram]
Done→ Select and edge or axis that will appear: Horizontal and on the top→ select the top edge. In the following sketch window, draw 2 lines along the centers of the cross-section as shown below:

→ Click Done.

Repeat the same on the other side of the column. The partition sketches are made in order generate the required points to help in partitioning the column into equal cells.

We get the below result on both the ends:
8. **Partitioning the model into cells:**

Using ![image] partition the model into cells using the→ 3 points option. First make sure to partition the Model into 4 large cells along the x-y direction. i.e. we get 4 partitions of the cross-section shown below:

Then continue to partition using the 3 points command so as to obtain a partition of the below cross-section on all of the 4 sides:
9. **Assigning of material property:**

Double click on [Materials] → Assign name: Steel S355J2 → In General tab → Density → enter the following value:

![Mass Density]

Under Mechanical → Elasticity → Elastic → enter the following values → OK

![Young's Modulus and Poisson's Ratio]

Double click on [Sections] → Assign name: I Section → Solid → Homogeneous → Continue

In Edit Sections window → Material: Steel S355J2 → OK

![Edit Section]

From tool bar: Assign → Section → Select the column in the graphic window → Done → Section: I Section → OK → Select the column in the graphic window → Done
In the Edit Section Assignment window → Section: I Section → OK → Done.

10. **Assembly:**

Select instances under assembly in the model tree.

Under Create Instance window → Parts → select Column → Dependent → OK
11. Creating Reference points:

Under the Interaction Module → create a reference point at the center of the cross-section at the top and the bottom using as shown below:

Under ‘Column’ in the model tree → Double click on Sets → Name: Upper Nodes → Select whole surface on the upper cross-section holding down shift → Done.

Repeat the same for the lower nodes, this time giving the Name: Lower Nodes.

12. Making the top and bottom surfaces rigid:

Under in the model tree → double click on Constraints → Rigid body → Continue
select pin(nodes) → click on  
→ select ‘Lower Nodes’ from the sets  

→ For the reference point, select  
and pick on RP-1 from the graphic window. → OK.

Repeat the same for the upper nodes.

13. Meshing the part:

Under the ‘column’ in the model tree → double click on ‘Mesh’.

In toolbar, click on Seed → Part

In the Global Seed window → give Approximate Global seed to 0.05 → OK.

This will seed that column along the length for element sizes of 50mm.

In toolbar, click on Seed → Edges → select the outline of the cross-section line by line.
In the Basic tab → Select ‘By size’ → approximate element size: 0.008 → tick Curvature control → Maximum deviation factor: 0.1 → OK.

In the toolbar click on ‘Mesh’ → Part → OK to mesh the part?: Yes.

This completes the mesh for the column.
14. Creating Step:

Double click on ‘Step’ in the model tree→ Name: Linear Buckling→ Insert New Step after: Initial→ Procedure type: Linear Perturbation →Buckle→ Continue.

In Edit Step window→ Number of eigenvalues requested:5→ Maximum number of iterations:1500→OK.
15. Assigning Boundary Conditions:

Double click on \( \text{BCs} \) in the model tree

In the Create Boundary Condition window → Name: Top Pinned → Step: Linear Buckling → Mechanical → Displacement/Rotation → **Continue**.

In the graphic window → select RP-2 (reference point 2) → **Done**.
In the ‘Edit boundary Condition’ window → Tick off U1 and U2 → OK.

Follow the same for procedure → Name: Bottom pinned, but this time → select RP-1 → tick off U1, U2 and U3 as shown below:
Appendix 1: page14
Henry Mupeta, George John, Aliasgar Hirani
16. **Applying load:**

Double click on **Loads** in the model tree.

In the Create load window → Name: Load → Mechanical → Concentrated force → **Continue**.

In the graphic window → select RP-2 → done.
In the Edit Load window → Assign CF1:0, CF2:0, CF3: -1 → OK.

17. Editing Keyword:

Right click on Model-1 → click on Edit Keyword.

In the Edit keywords window → click at the end of the last line….PRESELECT → click Add After → type “ *NODE FILE” → press Enter → in the next line type “U” → OK.

18. Creating a Job:

Double click on Jobs
In the ‘Create Job’ window → Name: Linear_Buckling_Analysis → Continue

In the ‘Edit Job’ window → OK.

Right click on the created job → Submit.
NON LINEAR BUCKLING ANALYSIS:

Right click on Model-1 → Copy Model→ Copy Model-1 to: Non-Linear Buckling Analysis→OK.

1. Creating the Non-Linear Buckling Step:

Expand the created model tree→ under steps delete the Linear Buckling step.

Double click on Steps (1)

In the Create Step Window→Name: Non-Linear Buckling→Procedure type→ General→ Static, Riks→ Continue
In the Edit Step window → Nlgeom: ON.
Appendix 1: page20

Henry Mupeta, George John, Aliasgar Hirani

In the Incrementation tab → Maximum number of increments: 50 → Arc length increment Initial: 0.01 → Arc length increment Minimum: 1E-045 → Arc length increment Maximum: 1E+036 → OK.

2. Applying load:

Double click on 

In the Create Load window → Name: Eigen Value Load → Category: Mechanical → Type for Selected Step: Concentrated Load → Continue.

In the graphic window → Select RP-2 → Done.
In the Edit Load Window → CF1: 0 → CF2: 0 → CF-3: -6.2267E+006 (value corresponding to Eigen mode at which buckling starts)

3. **Boundary conditions:**
Repeat the same as in the Linear Buckling step.

4. **Editing Keywords:**
   
   Right click on **Non-Linear Buckling Analysis** → Edit key words
IN the Edit Keyword window → After ** STEP: Non-Linear Buckling ** → click on Add after → and type "*IMPERFECTION, FILE=Linear_Buckling_Analysis, STEP=1(Press Enter) → 1, 0.0306 → OK"

*(Make sure to remove the modifications in the keywords created in the Linear buckling stage before creating the job.)*
5. Creating the Job:

Double click on 'Jobs’ under Analysis

In the Create job window ➔ Name: NonLinear_Analysis ➔ Continue

In Edit Job Window ➔ OK.
RESIDUAL STRESSES ANALYSIS:

Right click on **Non-Linear Buckling Analysis** → Copy Model → Copy Model-1 to: Residual Stress Analysis → OK.

1. Creating sets of elements to assign Residual stress values:

Select From the ‘Tools’ from the tool bar → Sets → Create

In the Create Set window → **Name:** Max_Tension_Flange → **Type:** Element → **Continue.**

Select the elements for the set by topology

In the graphic window,
Select the two sets of central stack of 3 elements as shown below:

Continue doing the same procedure for the stack of elements on the far end of the flange

This time, **Name: Max_Comp_Flange**

The selection of the elements are as shown below:
Continue creating sets with the following names and in the below shown pattern:

**Name: Max Comp Web**
Observe that for selection of the elements along the web, a stack of 4 elements are selected.

Now continue selecting the stack of elements center-outwards, each time selecting the stacks along the web and flange separately. Name the sets of elements on the web center-outwards as **Web1, Web2, Web3……etc.**

**Name: Web1**
Name: Web2
Name: Web3

Similarly, create the sets along the flange. Name them as **Flange1, Flange2, Flange3 .....etc.**
Name: Flange2
Name: Flange3
2. **Assigning Residual stresses to the sets of elements:**

   Double click on ![Predefined Fields](image) in the model tree.

   ![Create Predefined Field](image)

   In the Create Predefined Field, Name: `Max_Tension_Flange_Load`, Category: Mechanical, Stress, Continue.

   ![Region Selection](image)

   Click on `Sets...`

   In the Region Selection window, select ‘Max_Tension_Flange’.
IN the Edit Predefined Field → Sigma11: 0, Sigma22: 0, Sigma33: -1E+007, Sigma12: 0, Sigma13: 0, Sigma23: 0 → OK.

Continue assigning the stress values for the created sets using the values obtained for the stress distribution calculated using the formulae generated in excel.

3. Create Job and run the analysis:

Double click on jobs’

19. Creating a Job:

Double click on Jobs

In the ‘Create Job’ window → Name: Residual_stress_analysis → Continue
In the Edit Job window → **OK**.

Right click on the created job → **Submit**.
Faculty of Technology
351 95 Växjö, Sweden
Telephone: +46 772-28 80 00, fax +46 470-832 17